В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
йщз
йщз
03.10.2020 11:34 •  Информатика

Составить программу, в которой заменить все буквы а буквой о. (в pascal) (тема: двумерные массивы)

Ответ:
m1m2m3m4m571
m1m2m3m4m571
09.06.2020 11:55

program raf105;

var a:array[1..30,1..20] of string;

i,j,o:integer;

s:string;

begin

for i:=1 to 30 do

 for j:=1 to 20 do

   a[i,j]:= '';

writeln('Вводите слова по очереди');

writeln('Чтобы закончить введите 0');

repeat

 readln(s);

 if s <> '0'

   then

   begin

     o:= o+1;

     for i:=1 to length(s) do

       a[o,i]:= s[i];

   end;

until s = '0';

writeln;

writeln('Вывод:');

for i:=1 to o do

begin

 for j:=1 to 20 do

   if a[i,j] = 'а'

     then a[i,j]:= 'о';

 for j:=1 to 20 do

   if j <> 1

   then

   begin

     a[i,1]:= a[i,1] + a[i,j];

     a[i,j]:= '';

   end;

 writeln(a[i,1]);

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?