В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kristinabuslae
kristinabuslae
02.11.2020 00:08 •  Информатика

Подскажите, , где ошибки и как корректно составить программу? (в pascal) само : удвоить все символы в строке.

Ответ:
даяна92
даяна92
09.06.2020 11:31
Ошибка

В строке  's2:= s2 + s1[i] + s1[i];'

По умолчанию все переменные равны нулю

т.к. вы не задали значение i и вводите эту строку вне цикла for, то получается что вы запрашиваете нулевой элемент массива s1, при том что нумерация начинается с единицы, поэтому и выдаёт ошибку.

"Индекс находится вне границ массива"

Верный код программы

program raf105;

var s1,s2:string;

i:integer;

begin

writeln('Введите строку');

readln(s1);

s2:='';

for i:=1 to length(s1) do

 s2:= s2 + s1[i] + s1[i];

writeln(s2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?