В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Главрыба
Главрыба
31.01.2022 16:08 •  Информатика

Циклы в Паскале.
1)На клавиатуре вводятся 10 чисел. Составьте программу, определяющую произведения чисел, меньших 5.

2) На клавиатуре вводятся 10 чисел. Составьте программу, определяющую сумму чисел, меньших 25.

Ответ:
джем16
джем16
15.10.2020 01:54

1)

var n, i, s, k:integer;

begin

s:= 1;

k:=0;

for i:=1 to 10 do begin

readln(n);

if n < 5 then begin

s:=s*n;

k:=1;

end;

if k=1 then write(s) else write(0);

end.

2)

var n, i, s:integer;

begin

s:= 0;

for i:=1 to 10 do begin

readln(n);

if n < 25 then begin

s:=s+n;

end;

write(s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?