В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Лилия200000
Лилия200000
28.03.2021 16:41 •  Информатика

написать программу на языке паскаль нахождение корней квадратного уравнения при заданных a,b,c

Ответ:
Mastl
Mastl
15.10.2020 01:08

var a, b, c, x1, x2, e, d : real;

BEGIN

    WriteLn('Введите коэффициенты уравнения a,b,c:');

    ReadLn(a, b, c);

    d:= b*b - 4*a*c;

    e:= b/(2*a);

    if d<0 then WriteLn('Мнимые корни')

    else if d=0 then WriteLn('Корни квадратного уравнения: x1=x2', -e)

    else

        begin

             x1:= -e+sqrt(d)/(2*a);

             x2:= -e-sqrt(d)/(2*a);

             WriteLn('Корни квадратного уравнения: X1=', x1:6:2, ', X2=', x2:6:2);

        end

END.

0,0(0 оценок)
Ответ:
Aidanа1307
Aidanа1307
15.10.2020 01:08

главное не забыть про ; и точку в конце, а также не стоит забывать про значок *, который означает умножение и без него программа не заработает.


написать программу на языке паскаль нахождение корней квадратного уравнения при заданных a,b,c
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?