В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу вкладчику узнать, через сколько месяцев
необходимо забрать вклад из банка, если ему нужна сумма в S рублей, а
первоначальный вклад составил V рублей. Каждый месяц размер вклада
увеличивается на P процентов от имеющейся суммы.

Ответ:
vgrecuha6
vgrecuha6
06.08.2020 11:22

pascal:

var

s,v,p:real;

month:integer;

begin

month:=0;

readln(s,v,p);

while (v<s) do

begin

v:=v+(v/100*p);

month:=month + 1;

end;

writeln(month);

end.

c++:

#include <iostream>

using namespace std;

int calcMonth(int s,double v, int p)

{

   int month = 0;

   while(v<s)

   {

       v+=v/100*p;

       month++;

   }

   

   return month;

}

int main()

{

   int S,V,P;

   cin>>S>>V>>P;

   

   cout<<calcMonth(S,V,P);

   return 0;

}


Написать программу вкладчику узнать, через сколько месяцев необходимо забрать вклад из банка, если е
Написать программу вкладчику узнать, через сколько месяцев необходимо забрать вклад из банка, если е
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?