В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Max04032003
Max04032003
30.10.2022 06:40 •  Информатика

Составить программу. существует ли треугольник со сторонами a,b,c. если да определите будет ли он прямоугольным. ( сделайте для программы: pascalabc 8 по уровню 8-ого класса)

Ответ:
Error69
Error69
09.06.2020 05:48

Var a, b, i, c:Integer ;

Begin

Write('a=') ;read(a) ;writeln;

Write('b=') ;read(b) ;writeln;

Write('c=') ;read(c) ;writeln;

If (a<c+b) and(b<a+c) and(c<b+a) then begin

I:=1;

Write(' Треугольник существует ') ;

End Else begin

I:=0;

Write(' Треугольник не существует ') ;

End;

If i=1 then begin

If (a>b) and(a>c) then

If sqr(a) =sqr(b) +sqr(c) then write(' Треуголинк прямоугольный')

Else write(' Треугольник не прямоугольный ') ;

If (b>a) and(b>c) then

If sqr(b) =sqr(a) +sqr(c) then write(' Треуголинк прямоугольный')

Else write(' Треугольник не прямоугольный ') ;

If (c>a) and(c>b) then

If sqr(c) =sqr(b) +sqr(a) then write(' Треуголинк прямоугольный')

Else write(' Треугольник не прямоугольный ') ;

End;

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?