В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
бобик27
бобик27
15.02.2023 23:14 •  Информатика

Паскаль:через составной оператор Beginend составить программу, которая вычисляет сумму и среднее арифметическое положительных чисел

Ответ:
JHopeЧонХосочек
JHopeЧонХосочек
14.10.2020 23:08

Program p1;

Var a, i, n, k,z: integer;

Begin

Write('Введите количество чисел: ');

readln(n);

k:=0;

z:=0;

For i:=1 to n do begin

readln (a);

if (a > 0) then k:=k + a;

z:=z + 1;

end;

Writeln('Сумма положительных чисел = ',k);

Writeln('Среднее арифметическое чисел = ',k/z);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?