В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
xaetrmsmirnov
xaetrmsmirnov
30.05.2021 20:46 •  Информатика

Составить программу, которая вычисляет сумму и среднее арифметическое положительных чисел.

Ответ:
max697
max697
14.10.2020 23:00

Для начала каких чисел?

Они вводятся или нет?

Ох, ладно

Допустим, вводятся)

Python

Я ввожу число и все положительные числа, которые входят в него будут проходить через программу...

n = int(input())

g = 0

l = 0

for i in range(n+1):

   g += 1

   l += i

g -= 1

print( l // g )

Пример

Ввод: 5

Вывод: 3

Как получилось:

1+2+3+4+5=15

кол-во цифр = 5

15 / 5 =3

Как-то так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?