В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
apabud
apabud
22.08.2021 06:37 •  Информатика

Напишите программу, которая в последовательности натуральных чисел

определяет произведение чисел оканчивающихся на 5.Паскаль. Цикл for

Ответ:
radmirsatabalov
radmirsatabalov
14.10.2020 23:04

var

 a: array [1..10000] of integer;

 N: integer;

 i: integer;

 Product: integer;

begin

 product := 1;

 write('Введите количество элементов в массиве: ');

 readln(N);

 write('Введите элементы массива: ');

 for i:=1 to N do

 begin

   read(a[i]);

   if (a[i] mod 10 = 5) then

   begin

       product := product * a[i];

   end;

 end;

   

 write('Произведение элементов: ', product);

end.

0,0(0 оценок)
Ответ:
irinkaokhotina
irinkaokhotina
14.10.2020 23:04

Program p1;

Var a, i, n, k: integer;

Begin

Write('Введите количество чисел последовательности: ');  

readln(n);

k:=1;

For i:=1 to n do begin

readln (a);

if (a mod 10 =5) then k:=k*a;

end;

Writeln('Произведение чисел оканчивающихся на 5 - ',k);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?