В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
claer08
claer08
05.01.2020 05:43 •  Информатика

Написать программу подсчета суммы 1+2+3+…+n. n вводиться.

Ответ:
masharman250
masharman250
06.09.2020 17:59

Python

Программа:

n = int(input())

k = 0

for i in range(n+1):

   k += i

print(k)

Пример:

ввод:

4

вывод:

10

Как работает(по примеру):

1+2+3+4 =10

0,0(0 оценок)
Ответ:
Jelly1727
Jelly1727
06.09.2020 17:59

PascalABC.NET 3.6.2

begin

 Range(1, ReadInteger()).Sum.Println;

end.

Python 3

print( sum( i for i in range(1, int(input())+1) ) )

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?