В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zirkakoi
zirkakoi
08.06.2020 08:46 •  Информатика

Составить программу вычисления суммы чисел, делящихся на 4 от 1 до N. Используйте цикл while.

Ответ:
ohotniktv509
ohotniktv509
14.10.2020 21:53

Напишу сначала на простом языке по пунктам, потом на питоне:

считать N

x = 0 (счётчик)

s = 0 (сумматор)

пока x не равен N делать

x = x + 1

если x делится на 4, то s = s + x

цикл закончился

выводим s

Python:

n = int(input())

x = 0

s = 0

while x != n:

  x += 1

  if x % 4 == 0:

        s += x

print(s)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?