В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

) На известном вам языке программирования напишите программу:
Даны три целых числа. Определить количество положительных чисел.

Код программы:

Ответ:
00002017
00002017
14.10.2020 21:34

На Pascal:

var a,b,c,count:integer;

begin

readln(a);

readln(b);

readln(c);

count := 0;

if a > 0 then begin

  count := count + 1

end;

if b > 0 then begin

  count := count + 1

 end;

if c > 0 then begin

  count := count + 1

 end;

writeln(count);

end.

На Python:

a = int(input())

b = int(input())

c = int(input())

count = 0

if a > 0:

   count = count + 1

if b > 0:

   count = count + 1

if c > 0:

   count = count + 1

print(count)

Еще Python:

p = 0

for i in range(1,4):

   n = int(input())

   if n > 0:

       p += 1

print(f'Количество положительных чисел {p}')

0,0(0 оценок)
Ответ:
новенькая10
новенькая10
14.10.2020 21:34
ответ:

PascalABC.NET:

begin    Println('Количество:', ReadArrInteger(3).Count(x -> x > 0));end.Объяснение:

Println(a,b) - выводит на экран a и b, разделяя их пробелом.

ReadArrInteger(3) - возвращает массив из 3 введённых чисел.

.Count(x -> x > 0) - считает количество элементов массива, удовлетворяющим условию x > 0, где x - элемент.


) На известном вам языке программирования напишите программу: Даны три целых числа. Определить колич
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?