В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Тупка11
Тупка11
02.06.2020 18:34 •  Информатика

Склавиатуры вводится трехзначное число. составьте программу выводящую сумму его чисел.

Ответ:
olga7882
olga7882
24.05.2020 07:39

var
  a, s: integer; // целочисленный тип данных

begin
writeln('Введите число:');
  readln(a); // вводим число (можно больше трех знаков)
  while a <> 0 do  // пока остались цифры в числе выполнять...
  begin
    s := s + (a mod 10); // Отбираем последнюю цифру числа и прибавляем к сумме
    a := a div 10; // Стираем последнюю цифру числа
  end;
  writeln('Сумма цифр = ', s) // выводим результат
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?