В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Alise1sav
Alise1sav
26.06.2021 11:13 •  Информатика

1. написать программу, которая выводит все двузначные числа, которые имеют только три делителя. 2. написать программу, которая определяет, есть ли в записи натурального числа n заданная цифра определите, сколько раз выполнится цикл? a)a: = 4; b: = 6; while a < b do a: = a + 1; b)a: = 4; b: = 6; while a < b do a: = a + b; c)a: = 4; b: = 6; while a > b do a: = a + 1; d)a: = 4; b: = 6; while a < b do b: = a - b; e)a : = 4; b : = 6; while a < b do a : = a - 1;

Ответ:
akrikay13
akrikay13
09.06.2020 01:54
1)

program raf105;

var i,j,del:integer;

begin

for i:=10 to 99 do

begin

 del:=0;

 for j:=1 to i do

 begin

   if (i mod j)=0

     then del:= del+1;

 end;

 if del=3

   then writeln(i);

end;  

end.

2)

program raf105;

var a,b,c:integer;

x:boolean;

begin

write('Введите число: ');

readln(a);

write('Введите искомую цифру: ');

readln(c);

while a<>0 do

begin

 b:= a mod 10;

 if x=false

   then x:= b=c;

 a:= (a-b) div 10;

end;

if x

 then writeln('В ведённом числе есть искомая цифра')

 else writeln('В ведённом числе нет искомой цифры');

end.

3)

a) 2

b) 1

c) 0

d) 1

e) бесконечно

Язык программирования PascalABC

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?