В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Comalia
Comalia
04.06.2020 19:45 •  Информатика

Написать программы в pascalabc 1. даны два числа. удвойте большее число, утройте меньшее число. 2. у васи было 300 рублей. он решил купить несколько шоколадных батончиков по некоторой цене. хватит ли у него денег? напишите программу, которая запрашивает количество батончиков и цену батончиков. в результате должен появиться ответ "хватит денег" или "не хватит денег" и сколько денег останется в случае, если денег хватит. если же денег не хватит, то вывести, какой суммы не достает.

Ответ:
Мейвис00
Мейвис00
30.09.2020 14:44

Объяснение:

1.

var a, b: integer;

begin

read(a, b);

if a < b then

begin

a := a * 3;

b := b * a

end

else

begin

a := a * 2;

b := b * 3;

end;

print(a, b);

end.

2.

var kol, cen: integer;

begin

writeln('Введите количество и цену');

read(kol, cen);

if kol * cen < 300 then writeln('Хватит денег')

else writeln('Не хватит ', kol*cen - 300, ' рублей.')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?