В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
olesyamolyanova
olesyamolyanova
10.10.2021 02:34 •  Информатика

Написать программу,инвертирующее байтовое число. Т.е. число 25 превратит в -25. Число -127 превратит в 127.

Ответ:
Malika89551
Malika89551
14.10.2020 19:00

С++

#include <iostream>

int main() {

 char a = 25, b = -127;

 a = ~a;

 a++;

 b = ~b;

 b++;  

 printf("%d %d", a, b);

}

Версия с вводом числа (терминал)

#include <iostream>

int main() {

 char a;

 std::cout << "Type your num: ";

 std::cin >> a;

 a = ~a;

 a++;

 printf("Your inverse num: %d", a);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?