В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
andrej1790
andrej1790
11.02.2023 09:12 •  Информатика

Написать программу в паскале 70 для n введенных с клавиатуры чисел найти сумму положительных, кратных 3

Ответ:
artik269
artik269
08.06.2020 21:43

program raf105;

var a,b:integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

a:=1;

while a<>0 do

begin

 readln(a);

 if (a>0) and ((a mod 3)=0)

   then b:= b+a;

end;

writeln('Сумма положительных чисел, кратных трём: ',b);

end.

Язык программирования PascalABC

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?