В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Gunelka23333
Gunelka23333
13.09.2021 04:31 •  Информатика

На вход программы подается количество вводимых чисел, а затем сами числа. Определить сколько вводимых чисел кратных 13. Вывести количество этих чисел.
2) На вход программы подается количество вводимых чисел, а затем сами числа. Числа положительные, не превышающие 100. Определить максимальное число в последовательности. Вывести это число.

Ответ:
anait87
anait87
14.10.2020 17:23

1)

var

 a,i,count:integer;

begin

 readln(a);

 count:=0;

 for i:=1 to a do  

   begin

     readln(a);

     if a mod 13 = 0 then

       inc(count);

   end;

 writeln('Count: ',count);

end.

2)

var

 a,i,max:integer;

begin

 readln(a);

 for i:=1 to a do  

   begin

     repeat

       readln(a);

       if a>100 then

         writeln('Error.Repeat');

     until a<=100;

     if i = 1 then

       max:=a

         else

           if max < a then

             max:=a;

   end;

 writeln('Max: ',max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?