В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Alyona1247
Alyona1247
12.08.2020 06:40 •  Информатика

Дано четырехзначное число, составить программу подсчета количества нечетных цифр в этом числе и сообщение false(если таких цифр нет) и true (если есть).
Питон

Ответ:
Alisa2853
Alisa2853
06.09.2020 11:27

number = 4222

count = 0

number = str(number)  

number = list(number)

number = map(int, number)

for i in number:

   if i % 2 != 0:

       count += 1

if count == 0:

   print(count)

   print(False)

else:

   print('всего нечетных чисел:', count)

   print(True)

number = 4222

count = 0

( c комментариями)

number = str(number)

number = list(number)

number = map(int, number)

# переводим число в список

for i in number:

   if i % 2 != 0:

       count += 1

#находим нечетное число

if count == 0:

   print(count)

   print(False)

else:

   print('всего нечетных чисел:', count)

   print(True)

# выводим его

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?