В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Юлька6488262
Юлька6488262
03.12.2022 23:57 •  Информатика

На с++ составить программу, которая запрашивает у пользователя два целых числа и выводит сумму квадратов а^2+b^2 этих чисел. пример работы программы a=3 b=2 сумма квадратов равна 13.

Ответ:
Татьяна06111
Татьяна06111
08.06.2020 19:33

#include <iostream>

#include <cmath>  // подключаем файлы с библиотекой для возведения в степень

using namespace std;

 

int main() {

   long long a, b;  // инициализируем 2 переменных типа long long

   cin >> a >> b;  // вводим числа

   cout << 1LL * (pow(a, 2) + pow(b, 2))  << endl;  // выводим результат

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?