В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Wikwsejjj
Wikwsejjj
10.06.2021 01:23 •  Информатика

Напишите программу для решения следующей : с клавиатуры вводятся 25 пар чисел. вывести на экран только те пары, сумма которых больше 100

Ответ:
AndruxaS
AndruxaS
08.06.2020 19:21

Python 3:

l = [] # создание списка для хранения пар чисел

for i in range(25): # начало цикла

   n, m = map(int,input().split()) # ввод чисел

   if n + m > 100: # проверка условий

       l.append([n, m]) # добавление пары в список

for i in l:

   print(*i) # вывод пар

0,0(0 оценок)
Ответ:
Nastya6376
Nastya6376
08.06.2020 19:21
const    N = 25;var    arr: array[1..N, 1..2] of real;    firstNumber, secondNumber: real;    i, j: integer;begin    for i := 1 to N do        begin            Readln(firstNumber, secondNumber);                        Writeln();                        if (firstNumber + secondNumber > 100) then                begin                    j := j + 1;                                        arr[j, 1] := firstNumber;                    arr[j, 2] := secondNumber;                end;        end;        Writeln();        for i := 1 to j do        Writeln(arr[i, 1], ' | ', arr[i, 2]);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?