В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SofiyaSofiaro
SofiyaSofiaro
03.09.2020 16:08 •  Информатика

Написать программу на паскале, используя цикл: 1) посчитать сумму четных чисел, меньших или равных n s = 2 + 4 + 6 + … + n 2. найти сумму нечётных цифр числа 3. возвести число в степень.

Ответ:
Champagne
Champagne
30.09.2020 14:22

Объяснение:

// Возведение в степень

program stepen;

var

p,i,n, a:integer;

begin

write('введите число и степень');

readln(a,n);

p:=1;

for i:=1 to n do p:=p*a;

writeln('Число ',a, ' в степени ',n,' = ',p);

readln;

end.

//Сумма нечетных цифр числа

program project1;

var

a, b, s : integer;

begin

s := 0;

write('введите число: ');

readln(a);

while a <> 0 do

begin

b := a mod 10;

if b mod 2 <> 0 then s := s + b;

a := a div 10

end;

writeln('сумма нечетных цифр: ', s);

readln;

end.  

//Сумма четных чисел до n

program summach;

var

S,n,i:integer;

begin

Write('Введите n=');

readln(n);

if n mod 2<>0 then n:=n-1;

n:=n div 2;

s:=0;

for i:=1 to n do

s:=s+2*i;

writeln('s=',s);

readln;

end.    

//

//   сумма четных с циклом repeat

program summach1;

Write('Введите n=');

readln(n);

if n mod 2<>0 then n:=n-1;

s:=0;i:=1;

repeat

s:=s+2*i;

i:=i+1;

until 2*i>n ;

writeln('n=',n);

writeln('s=',s);

readln;            

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?