В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sayyoraibragim
sayyoraibragim
21.01.2021 16:11 •  Информатика

Составить на паскале: 1) программу для вычисления суммы ряда s=1+ 1/2+1/3+1/4+..+1/n. число n вводится с клавиатуры. 2) одноклеточная амеба каждые 3 часа делиться на 2 клетки. определить, сколько амеб будет через 3,6,9,12 и 24 часа. 3) дано натуральное числоо n и действительное число х. вычислить сумму ряда sin(x)+sin(2x)+sin(3x)++sin(nx). 4) написать программу для вычисления n-ой степени числа а. , )

Ответ:
Elirgon88
Elirgon88
08.06.2020 15:27

1)

var

  s : real;

  i, n : integer;

begin

  s := 0;

  read (n);

  for i := 1 to n do s := s + 1 / i;

  writeln (s);

end.

 

2)

var

  a, i : integer;

begin

  a := 1;

  for i := 1 to 8 do

  begin

    a := a * 2;

    writeln ('Через ', i * 3, 'часов будет ', a, ' амеб');

  end;

end.

 

3)

var

  n, i : integer;

  x, s : real;

begin

  s := 0;

  read (n, x);

  for i := 1 to n do

    s := s + sin (i * x);

  writeln (s);

end.

 

4)

var

  n, a, r, i : integer;

begin

  r := 1;

  read (a, n);

  for i := 1 to n do r := r * a;

  writeln (r);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?