В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dbb26444
dbb26444
12.04.2022 17:25 •  Информатика

НАДО СЕГОДНЯ СДАТЬ!! Написать программу которая запрашивает массив из n целых чисел а затем определяет количество четных элементов и количество нечетных элементов и выводит их количество, а также сам исходный массив.

2. Написать программу которая запрашивает массив из н целых чисел, а затем складывает все положительные элементы и все отрицательные элементы и выводит их суммы, а также сам исходный массив.

Ответ:
Виталий0003
Виталий0003
14.10.2020 13:10

def parity(array):

   count_chet = 0

   count_nechet = 0

   for i in array:

       if i % 2 == 0:

           count_chet += 1

       else:

           count_nechet += 1

   print('четные числа => ', count_chet)

   print('нечетные числа =>', count_nechet)

   print('кол-во чисел =>', count_nechet + count_chet)

   print(array)

   

parity([1, 2, 4, 5, 7, 8])

(в parity можешь подставить любой массив)

2-ое задание

def suma(numbers_array):

   print(sum(numbers_array))

   print(numbers_array)

suma([1, 2, -4, 5, 7, 8])

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?