В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Weltrаum
Weltrаum
10.07.2022 09:58 •  Информатика

Составить программу, вычисляющую площадь треугольника в паскаль

Ответ:
абдулоахмед1
абдулоахмед1
14.10.2020 12:24

program z1;

var a,b,c,p: real;

begin

writeln('Определение площади треугольника по теореме Герона');

writeln('Введите стороны треугольника');

write ('a = ');

readln(a);

write ('b = ');

readln(b);

write ('c = ');

readln(c);

if (a + b <= c) or (b + c <= a) or (a + c <= b) then writeln ('Треугольника с такими сторонами не существует')

else

begin

p:=(a+b+c)/2;

writeln('Площадь треугольника равна ',sqrt(p*(p-a)*(p-b)*(p-c)):0:3)

end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?