В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mksmsslvp0b481
mksmsslvp0b481
18.05.2022 17:14 •  Информатика

Написать программу, которая, используя подходящую подпрограмму, возводит число х в степень n. Как можно проще.

Ответ:
avorob
avorob
12.08.2020 21:51

Відповідь:

Если язык указать сложно - вот питон:

def stepen(x,n):

   return x**n

x = 4

n = 5

print(stepen(x,n))

либо можно максимально коротко:

def stepen(x,n):

   return x**n

print(stepen(3,2))

если нужно,чтобы ты сам вводил x и n, то:

def stepen(x,n):

   return x**n

x = float(input("x = "))

n = float(input("n = "))

print(stepen(x,n))

Пояснення:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?