В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Julia20033112
Julia20033112
30.10.2021 08:15 •  Информатика

Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое (решите через

Ответ:
olya355
olya355
06.05.2020 14:30

ответ:const

 n = 10;

var

 a, summ, i:integer;

begin

 randomize;

 summ := 0;

 for i := 1 to n do

 begin

   a := random(20) + 1;

   summ := summ + a;

   write(a, ' ');

 end;

 writeln;

 writeln('Среднее арифметическое этих чисел ',summ / n);

end.

Подробнее - на -

Объяснение:

0,0(0 оценок)
Ответ:
Pol111111111663
Pol111111111663
06.05.2020 14:30

const

 n = 10;

var

 a, summ, i:integer;

begin

 randomize;

 summ := 0;

 for i := 1 to n do

 begin

   a := random(20) + 1;

   summ := summ + a;

   write(a, ' ');

 end;

 writeln;

 writeln('Среднее арифметическое этих чисел ',summ / n);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?