В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SuperArtem52
SuperArtem52
03.06.2023 16:19 •  Информатика

Составить программу в паскале даны 2 действительных числа, не равные друг другу. меньшее из них заменить половиной их суммы, а большее- их утроенным произведением. ввод и вывод с комментариями.

Ответ:
pagan1977sanyap0apdo
pagan1977sanyap0apdo
08.06.2020 06:12

var a,b,c:real;

begin

   readln(a,b);

   if(a > b) then

       begin

           writeln('a Больше');

           c := a;

           a := a*b*3;

           b := (b+c)/ 2;

           writeln('a = ',a,'   b = ',b);

       end;

if(b > a) then

       begin

           writeln('b Больше');

           c := b;

           b := a*b*3;

           a := (a+c)/ 2;

           writeln('a = ',a,'   b = ',b);

       end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?