В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rodoskinatanya
rodoskinatanya
13.07.2021 12:54 •  Информатика

1. Написать программу нахождения суммы большего и меньшего из 3 чисел.
2. Разработать программу для нахождения корней квадратного уравнения.

К каждой программе написать построчно комментарии к выполняемым действиям,
т.е. уточнить, что именно происходит в программе на данном этапе.
var a:integer; {объявление переменной а целочисленного типа}
…..
if t > 10 then… {проверка условия t>10}
и т.д.

Ответ:
katyazabriyan
katyazabriyan
14.10.2020 06:21

Первая программа

var a,b,c: integer;

min, max, s: integer;

begin

writeln('Введите числа');

readln(a,b,c);

if (a>b) then max:=a else max:=b;

if (c>max) then max:=c;

if (a<b)then min:=a else min:=b;

if (c<min)then min:=c;

s:=max+min;

writeln('Сумма максимального и минимального числа =', s);

end.

Вторая программа

Она состоит из процедуры и выводит на экран начальное уравнение, корни уравнения и дискриминант.

program sqrturavnenie;

uses crt;

Var a, b, c:Real;

procedure sq(a, b, c:Real);

Var d, x1, x2:Real;

Begin

d:=b*b-4*a*c;

Writeln ('d= ', d) ;

If d>=0 then begin

x1:=(-b+sqrt(d)) /(2*a);

x2:=(-b-sqrt(d))/(2*a);

If x1=x2 then

Writeln ('x1= ', x1:6:2)

else

Writeln ('x1=', x1:6:2, 'x2= ', x2:6:2)

End

Else

Writeln ('Корней нет!');

End;

begin

Clrscr ;

Writeln ('a= ');

Readln (a);

Writeln ('b= ');

Readln (b);

Writeln ('c=') ;

Readln (c);

Writeln (a:6:2,'x*x+ ', b:6:2, 'x+ ', c:6:2);

sq(a, b, c);

Readln

end.

С комментариями будет трудно

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?