В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
joraninga
joraninga
16.12.2020 21:10 •  Информатика

Дана последовательность целых чисел написать программу которая должна выяснить является ли эта последовательность убывающей используйте паскаль,если можно,то с командой array

Ответ:
werwedsgfdg
werwedsgfdg
08.06.2020 03:28

program raf105;

var a:array[1..100] of integer;

i,b:integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

i:=1;

readln(a[i]);

while a[i]<>0 do

begin

 i:= i+1;

 readln(a[i]);

 if a[i]>=a[i-1]

   then b:=1;

end;

if b=1

 then writeln('Последовательность не является убывающей.')

 else writeln('Последовательность убывающая.');

end.

Программа написана на языке PascalABC.NET

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?