В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составить программу квадратного уровнения

Ответ:
эмсикалаш
эмсикалаш
24.05.2020 06:06

var  a,b,c,D,x1,x2:real;    
begin
readln(a,b,c);
D:=b*b-4*a*c;
if D<0 then Writeln('Только комплексные корни')
else

begin

d:=sqrt(d);

x1:=(-b+d)/(2*a);
x2:=(-b-d)/(2*a);
WriteLn('x1=',x1);
WriteLn('x2=',x2);
end;   
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?