В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Reginalolo
Reginalolo
15.11.2020 15:19 •  Информатика

Напишите программу на языке программирования паскаль, которая будет сравнивать 5 чисел между собой и выводить наименьшее

Ответ:
муза2007
муза2007
30.04.2020 16:30

program Hello;

var a,b,c,d,e, result : Integer;

function min(a,b : Integer) : Integer;

begin

if(a > b) then min := b else min := a;

end;

begin

a := 1;

b := 2;

c := 3;

d := 4;

e := 5;

result := min(min(min(a,b), min(c,d)), e);

writeln(result);

end.

Объяснение:

0,0(0 оценок)
Ответ:
silchuk2004
silchuk2004
30.04.2020 16:30

Код:

program Hello;

var a,b,c,d,e, result : Integer;

function min(a,b : Integer) : Integer;

begin

if(a > b) then min := b else min := a;

end;

begin

a := 1;

b := 2;

c := 3;

d := 4;

e := 5;

result := min(min(min(a,b), min(c,d)), e);

writeln(result);

end.

Подробнее - на -

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?