В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Zadrot233
Zadrot233
01.12.2020 04:46 •  Информатика

Напишите программу в паскале:
Программа получает на вход 15 натуральных чисел. Напишите программу, которая определит сумму чисел, кратных 11. Программа должна вывести одно число — сумму чисел, кратных 11.

Ответ:
СуПерКотАйН
СуПерКотАйН
29.04.2020 13:30

Сначала вводим n - количество чисел, затем в цикле n раз вводим число, сравниваем с текущим максимальным max, и, если максимальное меньше, вместо максимального записываем текущее число. В качестве начального значения max принимаем 0, т.к. любое натуральное число, делящееся на 4, больше 0.

var

 i, t, max, n: integer;

begin

 readln(n);

 max := 0;

 for i := 1 to n do

 begin

   readln(t);

   if (t mod 4 = 0) and (t > max) then

     max := t;

 end;

 writeln(max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?