В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vikaivanova12
vikaivanova12
22.02.2021 09:29 •  Информатика

Python и главное чтобы программа с работой. напишите программу, которая вычисляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.

Ответ:
наталья732
наталья732
30.09.2020 13:31

#a)

print('Input n: ')

n = input()

if int(n) < 0:

   print('Incorrect input')

else:

   sum = 0

   for i in range(int(n) + 1):

       sum += i

   print('Sum is ', sum)

##

#b)

print('Input n: ')

n = input()

if int(n) < 0:

   print('Incorrect input')

else:

  sum = 0

  for i in range(int(n) + 1):

      sum += i*i

  print('Sum is ', sum)

##

#c)

print('Input n: ')

n = input()

if int(n) < 0:

   print('Incorrect input')

else:

   sum = 0

   for i in range(0, int(n) + 1, 2):

       sum += i

   print('Sum is ', sum)

##

#d)

sum = 0

for i in range(10, 100, 1):

   sum += i

print('Sum is ', sum)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?