В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lisafoxxxxxxxx
lisafoxxxxxxxx
16.06.2022 16:32 •  Информатика

класс.
Python.
Дан массив, содержащий 8 положительных целых чисел, не превышающих 1000
Необходимо найти в этом массиве количество двузначных элементов, которые кратны числу 5,
и заменить каждый из таких элементов на это количество. Напишите программу для решения
этой задачи. В качестве результата программа должна вывести изменённый массив, по одному
элементу в строке.
Язык программирования Python.

Ответ:
lololo781
lololo781
04.08.2020 01:26

n = int(input())

#Сколько чисел

value = []

z = 0

for i in range(n):

   t = int(input())

   value.append(t)

   if t // 100 == 0 and t % 5 == 0:

       z += 1

for i in value:

   if i // 100 == 0 and i % 5 == 0:

       g = value.index(i)

       value.remove(i)

       value.insert(g, z)

for i in value:

   print(i)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?