В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ak067
ak067
31.01.2023 11:15 •  Информатика

Сделать программу на паскале.
Задание!Написать программу, которая бы запрашивала возраст женщины и сообщала, сколько лет ей осталось до
пенсии, либо что она уже пенсионер.

Ответ:
asellial
asellial
14.10.2020 00:15

program jjjfd;

const n=60;

var

i: integer;

begin

writeln('Введите свой возраст');

readln(i);

if i>n then writeln ('Вы на пенсии')

else writeln('Вам осталось ', n-i, ' лет до пенсии');

readln;

end.

Объяснение:

program jjjfd;

const n=60; // константа, обозначающая возраст выхода на пенсию

var

i: integer;

begin

writeln('Введите свой возраст');

readln(i); // считываем с клавиатуры переменную i

if i>n then writeln ('Вы на пенсии') // если введённое число больше 60, печатаем, что мадам на пенсии

else writeln('Вам осталось ', n-i, ' лет до пенсии'); // в случае, если мадам ещё нет 60, печатаем сколько лет до пенсии ей осталось

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?