В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

(35 изи ! ) написать программу вычисления суммы всех нечетных двузначных чисел написать 3 программы! через: 1)while 2)repeat 3)for

Ответ:
Snomeli
Snomeli
07.06.2020 18:38

Объяснение:

 var i,s:integer;

 begin

   i:=10;s:=0;

   for i:=10 to 99 do

   if i mod 2<>0 then s:=s+i;

  writeln('Сумма нечетных 2-значных чисел(for)',s);

  readln;

  i:=10;s:=0;

  while i<=99 do

    begin

      if i mod 2<>0 then s:=s+i;

      i:=i+1;

    end;

    writeln('Сумма нечетных 2-значных чисел(while)',s);

    readln;

    i:=10;s:=0;

   repeat

    if i mod 2<>0 then s:=s+i;

    i:=i+1;

   until i>99 ;

   writeln('Сумма нечетных 2-значных чисел(repeat)',s);

   readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?