В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vasipovismail
vasipovismail
02.06.2020 14:28 •  Информатика

Напишите программу, которая находит номер максимального элемента массива.
Входные данные
В первой строке задается одно натуральное число N, не превосходящее 1000 – размер массива.

Во второй строке вводятся N чисел – элементы массива (целые числа, не превосходящие по модулю 1000).

Выходные данные
Вывести одно число – значение максимального элемента в массиве.

Ответ:
erkinsultanov
erkinsultanov
13.10.2020 02:39

#include <iostream>

#include  <math.h>

 

using std::cout;

using std::cin;

 

int main (){

int N,b,c,k;

cin >> N;

c = 0;

k = 0;

for (int i = 0; i != N ; i++){

   cin >> b;

   if(i==0)

    {

     c=b;

    }

else

 {

   if (c < b){

       c = b;

   }    

   }

   

}

cout << k;

 

return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?