В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Joshler0canon
Joshler0canon
15.03.2023 05:52 •  Информатика

Решите задачи на Паскале: 1) Из введенной последовательсти чисел, найдите количество чисел, кратных 3. 2) Из введенной последовательности чисел, найдите трёхзначные числа. 3)Написать программу для подсчета суммы квадратов чисел от 1 до 10.

Ответ:
4213566
4213566
06.08.2020 18:16

PascalABC.NET 3.5.1 + .NET Framework 4.7.1

#1

begin

 var A := ReadSeqInteger('enter seqeunce: ',ReadInteger('seq length: '));

 A.Where(p -> p mod 3 = 0).Count.Println;

end.

#2

begin

 var A := ReadSeqInteger('enter seqeunce: ',ReadInteger('seq length: '));

 A.Where(p -> (p>=100) and (p <= 999)).ToList.Println;

end.

#3

begin

 Range(1,10).Select(p -> p * p).sum.Println;

end.

Объяснение:

0,0(0 оценок)
Ответ:
busiginanst99
busiginanst99
06.08.2020 18:16

var n,a,b,c: integer;

begin;

read(n);//количество чисел в последовательности

for a:=1 to n do begin

 read(b);

 if (b mod 3)=0 then c:=c+1;

 end;

 write (c);

end.

var n,a,b,c: integer;

begin;

read(n);//количество чисел в последовательности

for a:=1 to n do begin

 read(b);

 if (b div 100)>0 then c:=c+1;

 end;

 write (c);

end.

var n,a,b,c: integer;

begin;

for a:=1 to 10 do begin

c:=c+(a*a);

 end;

 write (c);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?