В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
мик271
мик271
30.06.2021 10:16 •  Информатика

Написать программу на языке Паскаль, которая получает на вход (вы вводите с клавиатуры) трехзначное число, а затем однозначное, программа проверяет, есть ли однозначное число в трехзначном в виде одной из его цифр, программа должна вывести ответ на экран "да есть" или "такой цифры нет"
Выполняя это задание назовите любую из переменных своим именем.

Ответ:
Vlada12092009
Vlada12092009
12.10.2020 21:41

PascalABC.NET

begin

 var Глебов := ReadInteger('Введи трехзначное положительное число:');

 var Цифра := ReadInteger('Введи цифру от 0 до 9:');

 while Глебов > 0 do

 begin

   if Цифра = Глебов mod 10 then

   begin

     Print('да, есть');

     exit

   end;

   Глебов := Глебов div 10

 end;

 Print('такой цифры нет')

end.

0,0(0 оценок)
Ответ:
masterpop15432
masterpop15432
12.10.2020 21:41

var trehznachnoe,odnoznachnoe: integer;

begin

write('Введите трехзначное число, а затем однозначное: ');

readln(trehznachnoe,odnoznachnoe);

if (trehznachnoe mod 10 = odnoznachnoe) then

writeln('да есть')

else if ((trehznachnoe div 10) mod 10 = odnoznachnoe) then

writeln('да есть')

else if ((trehznachnoe div 100) mod 10 = odnoznachnoe) then

writeln('да есть')

else writeln('такой цифры нет');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?