В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alina090920031
alina090920031
20.12.2021 13:54 •  Информатика

Напишите программу нахождения наибольшего значения среди трёх величин: A, B, C​

Ответ:
Mausssslaaaa
Mausssslaaaa
13.10.2020 13:47

var

a,b,c,max:integer;

begin

read(a,b,c);

if a > b then

max:=a

else

max:=b;

if max > c then

write(max)

else

write(c);

end.

0,0(0 оценок)
Ответ:
ТвОяДеВкА
ТвОяДеВкА
13.10.2020 13:47

a=int(input('Введите первое число: ')

b=int(input('Введите второе число: ')

c=int(input('Введите третье число: ')

if a > b and c:

  print('Наибольшее число: ',a)

elif b > a and c:

  print('Наибольшее число: ',b)

else c > b and a:

  print('Наибольшее число: ',c)

Объяснение:

Первые три команды отвечают за добавление переменным значение, которые будут введены пользователем.

if,elif,else ставят условие, при котором будет выполнено следующие условия, так как переменных 3, то мы вводим ее три раза, каждый раз редактируя ее.

Все они сделаны по таком принципу, если True(правда), то выполнить действие, если False(неправда), то действие отменяется.

В данных командах написано, если а больше b и c, то выполнится условие и на экран выведится текст, с наибольшем числом a.

Если условие не выполняется, программа переходит к условию ниже, если оно аналогично не выполняется, оно переходит к третьему.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?