В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Avakado01
Avakado01
14.01.2021 05:17 •  Информатика

Напишите программу в Pascal ABC: существует ли треугольник со сторонами а, b, с. Если существует, то какой он - тупоугольный, прямоугольный или остроугольный.

Ответ:
Ijony
Ijony
13.10.2020 21:54

var a,b,c: double;

begin

write('Введите a: ');

readln(a);

write('Введите b: ');

readln(b);

write('Введите c: ');

readln(c);

if (a<b+c) and (b<a+c) and (c<a+b) then begin

if (a*a+b*b<c*c) or (a*a+c*c<b*b) or (b*b+c*c<a*a) then

writeln('Треугольник существует. Он тупоугольный')

else if (a*a+b*b=c*c) or (a*a+c*c=b*b) or (b*b+c*c=a*a) then

writeln('Треугольник существует. Он прямоугольный')

else writeln('Треугольник существует. Он остроугольный')

end

else  writeln('Треугольник не существует.')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?