В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Orlanboool
Orlanboool
01.03.2023 16:23 •  Информатика

НУЖНА Т-Т
Нужно составить программу в паскале.
Дан массив из 20 элементов,заполненный случайными числами от -15 до 30. Нужно найти номера максимального и минимального элементов этого массива.

Ответ:
Pandi2
Pandi2
28.08.2020 13:20

1.

program z1;

const n=20;

var a:array [1..n] of integer;

i,maxi,mini:integer;

begin

maxi:=1;

mini:=1;

write('Массив А: ');

for i:=1 to n do

begin

a[i]:=random(46)-15;

if a[i] > a[maxi] then maxi:=i;

if a[i] < a[mini] then mini:=i;

write(a[i],' ')

end;

writeln;

writeln('Максимальный элемент a[',maxi,'] = ',a[maxi]);

writeln('Минимальный элемент a[',mini,'] = ',a[mini])

end.

2.

program z1;

const n=20;

var a:array [1..n] of integer;

i,max,min:integer;

begin

max:=-15;

min:=30;

write('Массив А: ');

for i:=1 to n do

begin

a[i]:=random(46)-15;

if a[i] > max then max:=a[i];

if a[i] < min then min:=a[i];

write(a[i],' ')

end;

writeln;

for i:=1 to n do

begin

if a[i]=max then writeln('Максимальный элемент a[',i,'] = ',a[i]);

if a[i]=min then writeln('Минимальный элемент a[',i,'] = ',a[i])

end

end.

Объяснение:

1. Не учитывает повтор элементов. Ищет первый максимальный и первый минимальный элементы.

2. Учитывает повтор элементов, но надо точно задавать max и min исходя из диапазона чисел.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?