В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
шкуровоз
шкуровоз
20.10.2021 14:29 •  Информатика

Нужно составить программу в паскале.
Дан массив из 20 элементов,заполненный случайными числами от -15 до 30. Нужно найти номера максимального и минимального элементов этого массива.
Заранее

Ответ:
чудовкедах333
чудовкедах333
26.04.2020 02:30

ответ:program q174147740;

var

 i, max, min: integer;

 a: array [1..20] of integer;

begin

 Randomize;

 for i := 1 to 20 do

 begin

 a[i] := Random(100);

 Write(a[i]:3);

 if (i = 1) then

 begin

  max := a[i];

  min := a[i];

 end

 else

 begin

  if (a[i] > max) then

   max := a[i];

  if (a[i] < min) then

   min := a[i];

 end;

 end;

 WriteLn;

 WriteLn('Сумма: ', max + min);

 ReadLn;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?