В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
БУЛИЧКА23
БУЛИЧКА23
13.05.2021 18:11 •  Информатика

Написать программу для решения следующих задач:
1) Вывести на экран все двузначные числа:
а) В столбик
б) В строчку
2) Вывести на экран целые числа из интервала [-15; 10];
3) Вывести на экран целые числа из интервала [-5; 5] в обратном порядке;
4) Вывести на экран все четные двузначные числа;
5) Найти и вывести на экран сумму всех двузначных чисел;
6) Найти и вывести на экран сумму всех целых чисел из интервала [-100; 51];

Ответ:
Demians
Demians
24.04.2020 08:30

1) 

var a:array [1..100] of integer;

n,i:integer;

begin

for i:=10 to 99 do begin

a[i]:=i;

if (a[i] mod n=0) then writeln(a[i]);

end;

end.

 

 2)

var a:array [1..100] of integer;

n,k,i,x,y,z: integer;

begin

readln(n,k);

for i:=n to k do begin

a[i]:=i;

x:=a[i] mod 10;

y:=a[i] div 10;

z:=y mod 10;

y:=y div 10;

if (x=y) or (x=z) or (y=z) then writeln(a[i]);

end;

end.

 

 3)

 var a,n,an,na: integer;

begin

readln(a,n);

if (a>0) and (b>0) then begin

an:=a*10+n;

na:=n*10+a else writeln('Введены неверные числа!');

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?