В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
moaariishkkaa
moaariishkkaa
15.10.2022 05:49 •  Информатика

написать программу , которая подсчитывает сумму натуральных чисел от 1 до n (с циклом for, while, repeat

Ответ:
reki45
reki45
24.08.2020 01:52

ЦИКЛ FOR:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

for i:=1 to n do

s:=s+i;

writeln('Сумма равна ',s);

end.

ЦИКЛ WHILE:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

i:=1;

while (i<=n) do

begin

s:=s+i;

i:=i+1;

end;

writeln('Сумма равна ',s);

end.

ЦИКЛ REPEAT:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

i:=1;

repeat

s:=s+i;

i:=i+1;

until i>n;

writeln('Сумма равна ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?