В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Avetazatan
Avetazatan
05.11.2021 07:49 •  Информатика

Паскаль
1. Напишите программу, которая в последовательности натуральных чисел определяет сумму
чисел, кратных 2 и оканчивающихся на 8. Программа получает на вход целые числа,
количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0
(0 – признак окончания ввода, не входит в последовательность).
В последовательности всегда имеется число, удовлетворяющее условию
Программа должна вывести одно число: сумму чисел, кратных 2 и оканчивающихся на 8.

Ответ:
Lovecoffe777
Lovecoffe777
13.10.2020 19:24

var a, sum:integer;

begin

writeln('Введите числа (цифра 0 - выход из программы)');

readln(a);

while(a <> 0) do begin

if (((a mod 2) = 0) and ((a mod 10) = 8)) then

 sum:= sum + a;

readln(a);

end;

writeln('Сумма: ', sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?