В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tarantilla
tarantilla
03.07.2021 00:20 •  Информатика

Написать программу:Ввести символ. Вывести строку трех подряд идущих в алфавите символов: предыдущего, текущего и последующего. Пример: Вход: d Выход: cde

Ответ:
ElyalyaЗ
ElyalyaЗ
13.10.2020 19:20

Снизу код:

Объяснение:

#include <bits/stdc++.h>

using namespace std;

int main()

{

   char a;

   char b;

   char c;

   cin >> a;

   b = a - 1;

   c = a + 1;

   cout << b;

   cout << a;

   cout << c;

}

UPD: когда заводишь переменную char то если в этот чар забить число выведется символ например: char a = 49 если вывести a получится 1. таблица ASCII в

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?