В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
джания
джания
29.10.2022 10:54 •  Информатика

1) Написать программу, которая вводит натуральное число N и выводит первые N натуральных чисел.
2) Написать программу, которая вводит натуральные числа А и В, и выводит квадраты натуральных чисел в диапазоне от А до В.

Ответ:
krasilovaen
krasilovaen
13.10.2020 19:21

1 программа:

var a, i:integer;

begin

write('Введите натуральное число: ');

readln(a);

if (a <= 0) then

writeln('Ошибка')

else begin

for i:=1 to a do

  writeln(i);

end;

end.

2 программа:

var a, b, i:integer;

begin

write('Введите 1 число: ');

readln(a);

if (a < 0) then

 writeln('Ошибка')

else begin

 write('Введите 2 число: ');

 readln(b);

 if (b < 0) then

   writeln('Ошибка')

 else begin

   for i:=a to b do begin

   writeln(i*i);

end;

end;

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?