В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Макс777333
Макс777333
18.10.2021 23:18 •  Информатика

Составить программу, печатающую слово ИСТИНА, если указанное высказывание является истинным, и ЛОЖЬ в противном случае: даны три стороны одного и три стороны другого треугольника. Эти треугольники равновеликие, т.е. имеют равные площади.​

Ответ:
sleep13
sleep13
13.10.2020 17:33

#include <iostream>

#include <cmath>

using namespace std;

#define ld long double

struct triangle{

   ld a;

   ld b;

   ld c;

};

ld square(triangle t){

   ld p = (t.a + t.b + t.c)/2;

   return sqrt(p * (p - t.a) * (p - t.b) * (p - t.c));

}

triangle t1,t2;

void solve(){

   if(square(t1) == square(t2))

       cout << "ИСТИНА";

   else

       cout << "ЛОЖЬ";

}

signed main() {

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   cin >> t1.a >> t1.b >> t1.c >> t2.a >> t2.b >> t2.c;

   solve();

}

0,0(0 оценок)
Ответ:
milenabalayan
milenabalayan
13.10.2020 17:33

// PascalABC.NET

function КвадратПлощади(a, b, c: real): real;

begin

 var p := (a + b + c) / 2; // полупериметр

 Result := p * (p - a) * (p - b) * (p - c)

end;

begin

 var eps := ReadReal('Точность решения:');

 var (a, b, c) := ReadReal3('Сторона треугольника 1:');

 var s1 := КвадратПлощади(a, b, c);

 (a, b, c) := ReadReal3('Сторона треугольника 2:');

 var s2 := КвадратПлощади(a, b, c);

 Print(if Abs(s1 - s2) <= eps then 'ИСТИНА' else 'ЛОЖЬ')

end.


Составить программу, печатающую слово ИСТИНА, если указанное высказывание является истинным, и ЛОЖЬ
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?